В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sladkoe102
sladkoe102
09.06.2020 04:44 •  Информатика

Составьте программу, которая запрашивает четыре числа с клавиатуры и определяет среди них количество четных чисел. readln (a, b, c, d); if d mod 2 =0 then k: =k+1; k: =0; составьте программу, которая позволяет определить, является ли треугольник со сторонами a, b, c равносторонним.

Ответ:
ktt9
ktt9
25.08.2020 14:46
Var
    i, n, prev, k: integer;

begin
    //1
    k := 0;
    for i := 1 to 4 do
    begin
        read(n);
        if n mod 2 = 0 then k := k + 1;
    end;
    writeln('K = ', k);
    //2
    k := 0;
    for i := 1 to 3 do
    begin
        read(n);
        if i = 1 then begin
            prev := n;
            k := k + 1;
        end
        else if n = prev then k := k + 1;
    end;
    
    if k = 3 then
        writeln('Равносторонний')
    else
        writeln('Не равносторонний');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?