В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Костя228337
Костя228337
24.10.2021 18:54 •  Информатика

Составить программу вычисления стоимости покупки с учётом скидки. скидка 3% предоставляется в том случае, если сумма покупки больше 500 рублей, 5% - если сумма больше 1000 рублей. в результате вывести итоговую стоимость покупки и размер предоставленной скидки.

Ответ:
timofeyzel
timofeyzel
03.10.2020 14:11
Var s:integer;
begin
write('Стоимость покупки = '); readln(s);
if s>1000
  then writeln('Скидка 5% (',s*0.05,' руб.), необходимо заплатить ',s*0.95)
  else if s>500
              then writeln('Скидка 3% (',s*0.03,' руб.), необходимо заплатить ',s*0.97)
              else writeln('Скидки нет');
end.

Пример:
Стоимость покупки = 600
Скидка 3% (18 руб.), необходимо заплатить 582
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?