В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
fogeimof
fogeimof
05.01.2020 14:49 •  Информатика

(abc paskal)нужно полностью составить программу,от начала и до конца: "дан массив из 10 целых чисел.удалите из него первый элемент кратный 3 "

Ответ:
Б45
Б45
25.09.2020 09:50
Var  a:array [1..10] of integer; 
       i,p:integer; 
begin 
  for i:=1 to 10 do begin   
    a[i]:=random(10);   
    if (a[i] mod 3 = 0) and (p=0) then p:=i;  end; 
  writeln(a); 
  for i:=p to 9 do   
    a[i]:=a[i+1]; 
  a[10]:=0; 
  writeln(a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?