В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
кит217
кит217
04.03.2023 11:57 •  Информатика

Написать программу вводя числа с клавиатуры без ограничения их количества (конец ввода - число 0), найти сумму положительных и произведение отрицательных чисел ..

Ответ:
Алёнушка43
Алёнушка43
28.05.2020 10:18

program c1;
var
a,b,n:longint;
Begin
a:=0;
writeln('Вводи числа sergei1906');

repeat
read(n);
if n>0 then b:=b+n;
if n<0 then a:=a*n;
until n=0;
Writeln('Сумма положительных чисел: ',b);
Writeln('Произведение отрицательных чисел: ',a);
End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?