В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
hdblin530
hdblin530
05.12.2022 10:31 •  Информатика

Составьте программу подсчета числа элементов встречающихся только в одном из массивов a(n) или b(n) одномерный массив

Ответ:
aynuran1
aynuran1
03.10.2020 14:01
Var  i, j, kolvo:Integer;  a, b:array[1..10] of Integer;begin;  randomize;    {Заполнение массивов}  for i:=1 to 10 do begin;    a[i] := random(0, 10);    b[i] := random(0, 10);  end;    {Вывод массива a}  write('Массив a = [', a[1]);  for i:=2 to 10 do begin;    write(', ', a[i]);  end;  writeln('];');  {Вывод массива b}  write('Массив b = [', b[1]);  for i:=2 to 10 do begin;    write(', ', b[i]);  end;  writeln('];');    {Непосредственно нахождение кол-ва уникальных элементов}  kolvo:=0;  for i:=1 to 10 do begin;     for j:=1 to 10 do begin;        if(a[i] = b[j]) then break;        if(j=10)then Inc(kolvo);     end;  end;  for i:=1 to 10 do begin;     for j:=1 to 10 do begin;        if(b[i] = a[j]) then break;        if(j=10)then Inc(kolvo);     end;  end;  writeln('Количество уникальных элементов массива: ', kolvo,'.');end.

Результат:
Массив a = [8, 10, 4, 9, 0, 1, 5, 8, 9, 8];Массив b = [4,   0, 1, 5, 6, 2, 2, 1, 3, 9];Количество уникальных элементов массива: 8.
Выглядит правдоподобно, но не проверял.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?