Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
миша741
06.02.2023 05:18 •
Информатика
Синформатикой! нужно написать следующую программу: найдите сумму всех четных чисел от 1 до 200
Ответ:
tanea201111
25.09.2020 08:15
Сумма всех четных чисел от 1 до 200 - это на самом деле сумма чисел
2+4+6+...+198+200.
1. Самый короткий вариант
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
Writeln(Range(2,200,2).Sum)
end.
Результат:
10100
2. Более длинный и более "школьный" вариант
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
var s:=0;
var i:=2;
while i<=200 do begin
s:=s+i;
i:=i+2
end;
Writeln(s)
end.
3. Совсем "тупой школьный" вариант (решение "в лоб")
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
var
i,s:integer;
begin
s:=0;
for i:=1 to 200 do
if i mod 2 =0 then s:=s+i;
Writeln(s)
end.
4. Улучшенный "школьный" вариант
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
var
i,s:integer;
begin
s:=0;
for i:=1 to 100 do s:=s+2*i;
Writeln(s)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
avdzhrr
03.06.2020 21:47
Что с информационной точки зрения, является целью и почему? а) работы с каталогом библиотеки. б) работа со словарём. в) учёбы в школе....
alexgreen5454
19.12.2020 03:07
По 3 примера декларативных и процедурных знаний)...
SawBilly
14.03.2022 10:27
Как называется устройство обработки информации...
Яков222
14.03.2022 10:27
Сколько символов содержит сообщение,написанное с 16-символьного алфавита,если объём его составил3/16 кбайта? , все последние с интернета не копировать....
GDA1
23.06.2021 02:13
Как назвать 1 словом из 10 букв прикладные программы для выполнения на компьютере конкретных...
милка1523
23.05.2022 16:49
10. Проектное задание. Найдите в Интернете частоты встречаемости русских букв (в процентах). Предложите неравномерный код, который при кодирова-нии русского текста даст...
максир
04.02.2023 15:31
Копирование файл На диске D есть три папки Есенин, Пушкин, Блок. Пользователь вырезал папку Есенин и оставил ее в папку Блок. Что при этом произошло? Выберите один вариант.1....
dsfsksgsms
11.07.2021 09:48
Павел составляет числовой ряд, получая его элементы по формуле i * 2 + 1, где i пробегает значения от 1 до 20. Ряд получился следующего вида: 3 + 5 + 7 +...+ 41. Составьте...
хорошист549
25.01.2022 19:27
На 3) Найдите модуль произведения 2-х введенных вами чисел. 4) Составить программу, зная стороны комнаты (а – ширина, b – длина, с – высота), найти, сколько рулонов...
Sk174
13.07.2021 17:51
я в этом ничего не понимаю):...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
2+4+6+...+198+200.
1. Самый короткий вариант
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
Writeln(Range(2,200,2).Sum)
end.
Результат:
10100
2. Более длинный и более "школьный" вариант
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
var s:=0;
var i:=2;
while i<=200 do begin
s:=s+i;
i:=i+2
end;
Writeln(s)
end.
3. Совсем "тупой школьный" вариант (решение "в лоб")
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
var
i,s:integer;
begin
s:=0;
for i:=1 to 200 do
if i mod 2 =0 then s:=s+i;
Writeln(s)
end.
4. Улучшенный "школьный" вариант
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
var
i,s:integer;
begin
s:=0;
for i:=1 to 100 do s:=s+2*i;
Writeln(s)
end.