В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
19Otlichnik19
19Otlichnik19
04.02.2021 01:45 •  Информатика

Написать программу в паскаль абс по теме функции. : найти сумму цифр трех чисел.

Ответ:
380661146235
380661146235
31.07.2020 19:53
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
function SoD(n:int64):integer;
begin
  Result:=0;
  while n>0 do begin
    Result+=n mod 10;
    n:=n div 10
    end
end;
    
begin
  var a:=ReadArrInteger('Введите три натуральных числа:',3);
  Write('Суммы цифр чисел: '); a.Select(x->SoD(x)).Println;
  Writeln('Общая сумма цифр всех чисел: ',a.Select(x->SoD(x)).Sum)
end.

Тестовое решение:
Введите три натуральных числа: 56325 23131 784545223
Суммы цифр чисел: 21 10 40
Общая сумма цифр всех чисел: 71
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?