В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mam1975
mam1975
31.05.2022 05:08 •  Информатика

Напишите программу на языке pascal, которая с цикла for to считала s: =1-2+3-4+5-6+7-8+9-

Ответ:
kesha326
kesha326
25.09.2020 06:34
Var n,i,s:integer;
begin
write('n = '); readln(n);
s:=0;
for i:=1 to n do 
 if i mod 2 =0 then s:=s-i else s:=s+i;
writeln('s = ',s);
end.

Пример:
n = 10
s = -5
0,0(0 оценок)
Ответ:
Mashshka
Mashshka
25.09.2020 06:34
Var n,s,i:integer;
begin
  write('введите n ');
  readln(n);
  for i:=1 to n do if i mod 2 <> 0 then s:=s+i else s:=s-i;
  writeln('s = ',s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?