Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Вова12345678912
20.12.2022 03:05 •
Информатика
Запишите программу циклического обмена значениями трех переменных a,b,c.схема циклического обмена: a-> b-> c.например если до обмена было: a=1,b=2,c=3,то после обмена должно стать: a=3,b=1,c=2 . выполнить трассировку
Ответ:
элизабет17471
03.10.2020 13:45
Var a,b,c,d:integer;
begin
write('введите a,b,c ');
readln(a,b,c);
d:=c;c:=b;b:=a;a:=d;
writeln('a = ',a,' b = ',b,' c = ',c);
end.
Тестовое решение:
введите a,b,c 3 2 1
a = 1 b = 3 c = 2
0,0
(0 оценок)
Популярные вопросы: Информатика
afia388
06.03.2020 03:21
Яп java написать программу, позволяющую получить словесное наименование школьных оценок....
йцццу
28.08.2022 15:07
Укажіть об’єкт текстового документа ms word,який має такі параметри: відступ, вирівнювання, міжрядковий інтервал. а) сторінка б) абзац в) символ г) малюнок...
Zekkin
28.08.2022 15:07
Назначение и основные особенности стандартных программ oc windows....
Starshine2007
28.08.2022 15:07
Как построить график в excel функция 4x 4+x^2...
vadim88768
16.06.2022 16:25
Напишите программу, выводящую слова «зачет», если введено число 3, 4 или 5 и «незачет», если введено число 1 или 2....
Zggzsbsnnzh
09.03.2023 18:38
Чертёжнику дан алгоритм: повторить 3 раз команда №1 сместиться на вектор (3,2) сместиться на вектор (2,1) кц сместиться на вектор (-9,-6) после выполнения этого алгоритма...
SQQQUAD
04.02.2023 07:20
Позволяет работать человеку с информацией впривычном для него виде....
atom33
20.08.2022 07:22
Даны числа: 1; 21; 138; 1655; 10082. Используя MS Excel, вычисли среднее арифметическое данных чисел....
Лолыч11
30.05.2021 00:44
Высота надводной части айсберга 30 м , это восьмая часть всей его высоты . на какую глубину айсберг уходит в воду?...
altynbekova2003
30.05.2021 00:44
Среда,четверг,пятница,суббота,воскресенье.мягкие и твердые согласные...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
write('введите a,b,c ');
readln(a,b,c);
d:=c;c:=b;b:=a;a:=d;
writeln('a = ',a,' b = ',b,' c = ',c);
end.
Тестовое решение:
введите a,b,c 3 2 1
a = 1 b = 3 c = 2