В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
miran3
miran3
08.11.2020 14:41 •  Информатика

Составить программу с ветвящейся структурой, используя условный оператор if для квадратного уравнения вида ax2+bx+c=0

Ответ:
Wikwsejjj
Wikwsejjj
03.10.2020 13:30
Var a,b,c,d:real;
begin
readln(a,b,c);
d:=sqr(b)-4*a*c;
if d<0 then writeln('Net kornei');
if d=0 then writeln('x=',-b/(2*a));
if d>0 then writeln('x1=', (-b-sqrt(d))/(2*a),' x2=',(-b+sqrt(d))/(2*a));
end.
0,0(0 оценок)
Ответ:
gnastasiya5
gnastasiya5
03.10.2020 13:30
Var a,b,c,x,x1,x2:real;
begin
writeln('');
readln(a,b,c);
d:=b*b-4*a*c;
if d<0 then writeln('корней нет');
if d=0 then x:=-b/2/a;
if d>0 then;
begin;
x1=:(-b+sqrt(d))/2/a;
x2:=(-2-sqrt(d))/2/a;
writeln('x1=',x1:10:2);
writeln('x2=',x2:10:2);
end;
end
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?