Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
орексе
17.03.2020 16:08 •
Информатика
Уровень b. напишите программу, которая сортирует массив и находит количество различных чисел в нем.
Ответ:
Sdkaj
24.09.2020 20:49
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
var a:=ArrRandom(ReadInteger('n='),10,99);
a.Println.Sorted.Println;
Writeln('Количество разных чисел ',a.Distinct.Count)
end.
Тестовое решение:
n= 20
60 33 12 47 79 81 33 26 73 98 82 81 71 70 96 48 13 66 29 85
12 13 26 29 33 33 47 48 60 66 70 71 73 79 81 81 82 85 96 98
Количество разных чисел 18
0,0
(0 оценок)
Популярные вопросы: Информатика
zorynastya
27.03.2021 16:02
Обчислити значення логічного виразу (4*3==6) && !(7-5 =0)...
Madara908
26.06.2022 11:10
Какие преимущества у интерпретируемых языков? 1)полный доступ к вызовам функций операционной системы и аппаратному обеспечению 2)они более снисходительны к ошибкам 3)высокая скорость...
Ainur0529
16.06.2022 07:27
У исполнителя Альфа две команды, которым присвоены номера: 1. прибавь 1; 2. умножь на b (b — неизвестное натуральное число; b ? 2).Выполняя первую из них, Альфа увеличивает число...
ARINA55T5
30.05.2023 18:00
Сообщение записанное буквами из 32 символьного алфавита содержит 200 символов Какой объём информации в килобайтах оно несёт ответ округлите до сотых...
Tini2311
01.11.2022 06:36
Что можно считать главным результатом машинного обучения? •Автоматизацию математических расчётов; •Выявление правил и закономерностей; •Обрабутку датасетов; •Консьруирование нейронных...
obito4891
25.04.2022 06:44
1)Записать выражение в традиционной математической форме: y=(5*SQR(x)-SQRT(x))/2*x...
koshka99
08.03.2022 16:47
В летнем лагере отдыхало 89 семиклассников (-а). 8 из них не любят компьютерные игры. 52 семиклассника (-ов) предпочитают квесты, 62 — симуляторы. Сколько ребят с одинаковым удовольствием...
apexXx
19.11.2022 11:41
Напишите код для HTML используя PHP Найдите объем конуса ,зная радиус основания и высоту...
Мойурок
09.03.2023 03:42
Племя Ацтеков пользуется 38 символьным алфавитом. Свод основных законов племени хранится на 256 глинянных табличках, на каждую из которых нанесено ровно 128 символов. Какое количество...
F92120554651
15.05.2020 06:27
какие тут правильные ответы? Заранее благодарю❤️...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
var a:=ArrRandom(ReadInteger('n='),10,99);
a.Println.Sorted.Println;
Writeln('Количество разных чисел ',a.Distinct.Count)
end.
Тестовое решение:
n= 20
60 33 12 47 79 81 33 26 73 98 82 81 71 70 96 48 13 66 29 85
12 13 26 29 33 33 47 48 60 66 70 71 73 79 81 81 82 85 96 98
Количество разных чисел 18