В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ира21fu
Ира21fu
29.01.2022 04:30 •  Информатика

С++ написать программу, которая проверяет, является ли квадратная матрица симметричной относительно главной диагонали. входные данные в первой строке записаны через пробел размер квадратной матрицы n (количество строк равно количеству столбцов) ( 1 ≤ n ≤ 100 ). в следующих n строках записаны строки матрицы, в каждой – по n натуральных чисел, разделённых пробелами. выходные данные программа должна вывести слово 'yes', если матрица симметричная, и слово 'no', если матрица несимметричная.

Ответ:
lenapelevina0
lenapelevina0
15.09.2020 23:52
//Dev C++ 4.9.9.2

#include <iostream>
using namespace std;

int main(){
    int n;
    cin>>n;
    cout<<endl;
    int **ma;
    ma=(int **)malloc(sizeof(int*)*n);
    for (int i=0;i<n;i++){
  ma[i]=(int*)malloc(sizeof(int)*n);}
    for(int i=0;i<n;i++){
            for(int j=0;j<n;j++)
              cin>>ma[i][j];
            cout<<endl;}
     for(int i=0;i<n-1;i++)
             for(int j=i+1;j<n;j++)
                         if(ma[i][j]!=ma[j][i]){
                         cout<<"NO";
                         cin.get();
                         cin.get();
                         return 0;}
     cout<<"YES";
     cin.get();
     cin.get();
     return 0;
}

Пример ввода:
4

1
2
3
4

2
1
2
3

3
2
1
4

4
3
4
1

Пример вывода:
YES
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?