В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kyasarin1
kyasarin1
25.01.2023 10:55 •  Информатика

Написать программу для паскаль абц, но при не слишком сложных операций. "пусть n - натуральное число и пусть означает 1*3*5**n для нечетного n и 2*4**n для четного n. вычислить " - факториал. т.ею нужно ввести натурально число(например 5), а программа должна посчитать произведение нечетных чисел(1*3*5=15)

Ответ:
danilrykov200
danilrykov200
15.09.2020 23:52
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var n,i: integer;
p:BigInteger;
begin
  p:=1;
  write('Введите N ');readln(n);
  if n mod 2<>0 then i:=1 else i:=2;
      while i<=n do begin
        p:=P*i;
        i:=i+2;
      end;
    writeln(p);
end.

Тест №1
Введите N 6
48

Тест №2
Введите N 5
15
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?