В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
resssnizisss
resssnizisss
09.05.2022 18:00 •  Информатика

Написать программу.дано четырехзначное число.определить , равен ли квадрат первой цифры кубу третьей цифры этого числа.

Ответ:
tanya732
tanya732
25.08.2020 14:17
Только один вариант дает положительный результат. Когда первая цифра числа и третья равны 1

//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a:integer;
begin
  write('Введите число ');readln(a);
  if ((a div 1000)=1)and  ((a div 10 mod 10)*(a div 10 mod 10)= 1)then
  writeln('квадрат первой цифры равен кубу третьей цифры этого числа')
  else
   writeln('квадрат первой цифры не равен кубу третьей цифры этого числа')
end.

Тест №1
Введите число 1214
квадрат первой цифры равен кубу третьей цифры этого числа

Тест №2
Введите число 2237
квадрат первой цифры не равен кубу третьей цифры этого числа
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?