Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
elizalove21345747
09.05.2023 03:44 •
Информатика
Дан двумерный массив a размерностью м*n. отсортировать все строки по возрастанию значений элементов.
Ответ:
ДианочкаР
13.08.2020 22:20
Const
M = 10; // Количество строк
N = 10; // Количество столбцов
var
arr: array [1..M, 1..N] of integer;
i,j,z,min,temp : integer;
begin
for j := 1 to M do
for i := 1 to N do
arr[j, i] := random(99);
writeln('Исходный массив:');
for j := 1 to M do
begin
for i := 1 to N do
write(arr[j, i] : 2, ' ');
writeln;
end;
for j := 1 to M do
begin
for i := 1 to N - 1 do
begin
min := i;
for z := i + 1 to N do
if arr[j, z] < arr[j, min] then
min := z;
temp := arr[j, min];
arr[j, min] := arr[j, i];
arr[j, i] := temp;
end;
end;
writeln;
writeln('Отсортированный массив');
for j := 1 to M do
begin
for i := 1 to N do
write(arr[j, i] : 2, ' ');
writeln;
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Den7373
10.02.2020 07:59
Напишите программу, которая выводит на экран квадраты всех чисел от 1 до 10. в программе пэйтон...
SanGrey
24.02.2023 21:09
Название устройства (датчика) для измерения угла поворота робота или скорости вращения?...
ЯхочуВхогвартс
29.02.2020 01:35
3. Реши уравнения.300: x=900 - 897125 - 3+у= 525 г...
jglodmflof
02.02.2023 10:17
Вычисли значение выражения 38 - (10+10)...
девчонка1999
02.02.2023 10:17
Писатели употребли эти слова в прямом или в переносом значении. для чего? спишите любое предложение 4 надо предложение...
Danila12312
02.02.2023 10:17
А) запишите число 5 в виде дроби с числителем 15 б) запишите число 8 в виде дроби с числителем 1664 в) запишите число 70 в виде дроби с числителем 560...
penny2912p0bvxj
02.02.2023 10:17
Автомобілем маз за один рейс перевезли 9 т вантажу, автомобілем белаз - на 54 т більше. у скіль- ки разів більше вантажу перевезли автомобілем белаз, ніж автомобілем маз?...
TATARIN001
02.02.2023 10:17
Сделать разбор слова рачьего под цифрой 1...
syltanchik1338
02.02.2023 10:17
Прочитайте словосочетания найдите в корнях выделенных слов с безударной гласной подберите проверочные слова и запишите по образцу...
olegstar74p0a994
02.02.2023 10:17
Составить слова с приставкой пре в значении...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
M = 10; // Количество строк
N = 10; // Количество столбцов
var
arr: array [1..M, 1..N] of integer;
i,j,z,min,temp : integer;
begin
for j := 1 to M do
for i := 1 to N do
arr[j, i] := random(99);
writeln('Исходный массив:');
for j := 1 to M do
begin
for i := 1 to N do
write(arr[j, i] : 2, ' ');
writeln;
end;
for j := 1 to M do
begin
for i := 1 to N - 1 do
begin
min := i;
for z := i + 1 to N do
if arr[j, z] < arr[j, min] then
min := z;
temp := arr[j, min];
arr[j, min] := arr[j, i];
arr[j, i] := temp;
end;
end;
writeln;
writeln('Отсортированный массив');
for j := 1 to M do
begin
for i := 1 to N do
write(arr[j, i] : 2, ' ');
writeln;
end;
end.