В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программы в ! 33. составьте программу для определения, кто из двух учащихся учится лучше. фамилии учащихся и их оценки по трем предметам вводить с клавиатуры. предусмотрите вариант, когда средние одинаковы. 34. программа запрашивает три числа и выводит на экран разность между максимальным и минимальным числами.

Ответ:
//Задание 33
const
  n = 2;
type
  student = record
    f: string;
    p1, p2, p3: integer;
  end;

var
  a: array[1..n] of student;
  m: array[1..n]of real;
  i: integer;
  s: real;

begin
  s := 0;
  for i := 1 to n do
  begin
    writeln('Введите фамилию ', i, ' ученика ');
    readln(a[i].f);
    writeln('оценки по 3 предметам ');
    readln(a[i].p1, a[i].p2, a[i].p3);
    if (a[i].p1 + a[i].p2 + a[i].p3) / 3 >= s then begin
      s := (a[i].p1 + a[i].p2 + a[i].p3) / 3;
      m[i] := s;
    end;
  end;
  if m[1] = m[2] then writeln('Средний учащихся одинаков')
  else if m[1] > m[2] then
    writeln(a[1].f, ' учится лучше')
  else  writeln(a[2].f, ' учится лучше')
end.

Тест №1
Введите фамилию 1 ученика
Иванов
оценки по 3 предметам
3 4 5
Введите фамилию 2 ученика
Петров
оценки по 3 предметам
4 4 4
Средний учащихся одинаков

Тест №2
Введите фамилию 1 ученика
Иванов
оценки по 3 предметам
3 4 4
Введите фамилию 2 ученика
Петров
оценки по 3 предметам
5 5 5
Петров учится лучше

//Задание 34
var a,b,c,min,max:integer;
begin
  readln(a,b,c);
  min:=a; max:=a;
  if b<min then min:=b;
  if b>max then max:=b;
  if c<min then min:=c;
  if c>max then max:=c;
  writeln(max-min);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?