В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Подскажите . запишите программу в кумире объявлен набор в школьную баскетбольную команду. известен рост каждого из n учеников, желающих попасть в команду. напишите программу подсчета кол-ва претендентов имеющих шанс попасть в команду,если рост игрока команды должен быть не менее 170 см

Ответ:
9854123g
9854123g
07.08.2020 13:57
Program players;
  var
    n, p, i: byte;
    height: word;
begin
  write('Кол-во желающих: ');
  read(n);
  p:=0;
  for i:=1 to n do
    begin
      write('Рост ', i, ' желающего: ');
      read(height);
      if height => 170 then
        p:=p+1;
    end;
  write('Претендентов: ', p);
end.

Предположительно, так.
0,0(0 оценок)
Ответ:
danek20063
danek20063
16.01.2024 21:22
Конечно, я могу помочь! Вот программа на языке Кумир, которая подсчитывает количество претендентов, чей рост составляет не менее 170 см:

```
{ Объявляем переменную для хранения количества претендентов }
var count: integer;

{ Получаем количество учеников }
write("Введите количество учеников: ");
var n: integer := readinteger;

{ Инициализируем счетчик }
count := 0;

{ Проверяем рост каждого ученика }
for var i: integer := 1 to n do
begin
write("Введите рост ученика ", i, ": ");
var height: integer := readinteger;

{ Проверяем, соответствует ли рост требованиям }
if height >= 170 then
count := count + 1;
end;

{ Выводим результат }
writeln("Количество претендентов, имеющих шанс попасть в команду: ", count);
```

Объяснение программы:
1. Сначала мы объявляем переменную `count`, которая будет хранить количество претендентов, имеющих шанс попасть в команду.
2. Затем мы запрашиваем количество учеников и сохраняем его в переменную `n`.
3. Инициализируем счетчик `count` значением 0.
4. Далее, с помощью цикла `for`, мы перебираем каждого ученика в диапазоне от 1 до `n`.
5. Внутри цикла мы запрашиваем рост каждого ученика и сохраняем его в переменную `height`.
6. После этого, мы проверяем, соответствует ли рост ученика требованиям (больше или равен 170 см). Если да, то увеличиваем значение `count` на 1.
7. По окончании цикла, выводим результат - количество претендентов, имеющих шанс попасть в команду.

Эта программа позволяет школьнику понять логику подсчета и дает возможность самому ввести данные (количество учеников и их рост). Результат будет показывать количество учеников, которые имеют шанс попасть в баскетбольную команду.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?