В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
malenkayakreyz
malenkayakreyz
06.05.2021 18:41 •  Информатика

Составить программу на вход количества чисел,а затем вводятся сами числа. составить программу для нахождения макс и мин из этих чисел. каким образом делать, не знаю.

Ответ:
Yar4ik03
Yar4ik03
03.10.2020 12:27
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a,i,min,max,n:integer;
begin
  write('Введите количество чисел ');
  readln(n);
  min:=MaxInt; //считаем, что мимнимальное - самое большое целое
  max:=-MaxInt;//считаем, что максимальное - самое маленькое целое
  for i:=1 to n do begin
    readln(a);
    if a>max then max:=a;
    if a<min then min:=a;
  end;
  writeln('Максимальное: ',max,'  минимальное: ',min);
end.

Тестовое решение:
Введите количество чисел 5
23
12
44
10
15
Максимальное: 44  минимальное: 10
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?