В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
serguhovaannagmail
serguhovaannagmail
15.12.2021 02:07 •  Информатика

Напишите программу, которая вводит с клавиатуры 15 реальных чисел, организовывает их хранение в массиве и определяет разность между максимальным и минимальным элементом массива.

Ответ:
ehadid
ehadid
24.09.2020 11:17
Const n=15;
var x:array[1..15] of real;
i:integer; max,min:real;
begin
for i:=1 to n do
 begin
 write('x[',i,']=');
 readln(x[i]);
 end;
max:=x[1]; min:=x[1];
for i:=2 to n do
 begin
  if x[i]>max then max:=x[i];
  if x[i]<min then min:=x[i];
 end;
writeln('max-min = ',max,' - ',min,' = ',max-min);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?