В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kurtsmolovp00xqx
kurtsmolovp00xqx
01.12.2020 08:51 •  Информатика

Составить программу моделирования автомата автомат фиксировал температуру воздуха на протяжении тёплого осеннего месяца (30 дней). в конце месяца на дисплей вывел: 1. температуру каждого дня за весь месяц 2. минимальную и максимальную температуру месяца 3. среднюю температуру месяца 4. отклонение температуры каждого дня от среднего значения

Ответ:
MoDeRFeeD3
MoDeRFeeD3
03.10.2020 12:14
Const n=30; 
var a:array[1..n] of integer;
i,min,max,s:integer; sr:real;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(11)+10;
 write(a[i]:6);
 end;
writeln;
min:=a[1]; max:=a[1]; 
s:=a[1];
for i:=2 to n do
 begin
 if a[i]<min then min:=a[i];
 if a[i]>max then max:=a[i];
 s:=s+a[i];
 end;
sr:=s/n;
writeln('min = ',min,' max = ',max,' sr = ',sr);
s:=0;
for i:=1 to n do write(a[i]-sr:6:1);
end.

Пример (для 10 дней):
Массив A:
    11    16    19    15    13    19    11    16    17    17
min = 11 max = 19 sr = 15.4
  -4.4   0.6   3.6  -0.4  -2.4   3.6  -4.4   0.6   1.6   1.6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?