В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Nikolayirh
Nikolayirh
20.04.2022 16:09 •  Информатика

Написать программу к : в программе генерируется два случайных числа a и b в диапазоне от 10 до 40. определить какое число больше?

Ответ:
Viktoria12311
Viktoria12311
07.09.2020 19:37
Если паскаль, лови...
Во первых для генерации рандомного числа используется метод random(x), но он генерирует число от 1 до x, и чтоб он генерировал от какого то определенного, надо из x вычесть от какого числа генерировать, а потом к сгенерированному прибавить его random(x - n) + n. Где x - До какого числа, а n - от какого. 
Для нахождения максимального числа мы будем использовать метод max, который принимает два аргумента (какие числа надо сравнить), допустим max(5,10) вернет 10, max(-1, -5) вернет -1. Так же есть min - нахождение минимального.
...
А теперь сам код:
begin
var a := random(30) + 10; 
var b := random(30) + 10;
writeln('a:' + a); 
writeln('b:' + b);
writeln(max(a,b)); 
end.
...
Если не сложно нажми " " ;)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?