В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
arujan20071
arujan20071
01.07.2020 19:32 •  Информатика

Написать программу на языке c++. перевести с рекурсивной функции conv (n, p) за- данное натуральное число n в p-ичную систему счисления (2 ≤ р ≤ 9).

Ответ:
Mizuki1111
Mizuki1111
03.10.2020 11:59
#include <iostream>
using namespace std;

void conv(int n, int p) {
if(n/p!=0){
        conv(n/p,p);
    }
    cout << n%p;
}
 int main()
{
    int n, p;
    string m;
    cout << "Введите n:", cin >> n, cout << "\n";
    cout << "Введите p:", cin >> p, cout << "\n";
    conv(n,p);
    return 0;
}

Пример:
Введите n: 511
Введите p: 8
777
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?