В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
AzalieySagaz
AzalieySagaz
14.02.2022 09:46 •  Информатика

Написать программу, которая просит ввести 10 целых чисел и считает сколько из них положительный, отрицательно и нулей

Ответ:
Ditroid
Ditroid
03.10.2020 11:47
Var a,n1,n2,n3,i:integer;
begin
  for i:=1 to 10 do begin
    write('Введите ',i, ' число ');
    readln(a);
    if a = 0 then n1:=n1+1 else
      if a<0 then n2:=n2+1 else n3:=n3+1;
   end;
   writeln('Равных 0 : ',n1);
   writeln('Меньше 0 : ',n2);
   writeln('Больше 0 : ',n3);
 end.
  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?