В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Tatyna83
Tatyna83
05.03.2021 01:11 •  Информатика

Написать программу: на концерте было k зрителя. из них k1 человек купили билеты по c1 рублей, а остальные-по с2 рублей. сколько денег (sum) было выручено от продажи билетов? (к=894 чел., к1=396 чел., с1=150 рублей, с2=200 рублей) объясните принцип действия оператора sum, не был на уроке, а ничего дельного не нашел

Ответ:
28.05.2020 05:33

Тут и обяснять особо нечего. Сначала вычесляем сколько было "остальных" зрителей, потом общую сумму от продажи k1 человекам, потом общую сумму от продажи k2(остальным) человекам, то и то складываем и присваиваем переменной sum.

program test;
var k, k1, k2, c1, c2, sum: integer;
begin
   k:=894;
   k1:=396;
   c1:=150;
   c2:=200;
   k2:=k-k1;
   sum:=k1*c1 + k2*c2;
   writeln('Sum = ', sum, ' rub');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?