В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
gopas11123
gopas11123
04.10.2022 17:50 •  Информатика

Даны две дроби a/b и c/d (a,b,c,d - натуральные числа). составить программу деления дроби на дробь. ответ должен быть несократимой дробью. использовать подпрограмму алгоритма евклида для определения нод

Ответ:
TimurZel
TimurZel
03.10.2020 11:43
Var  a, b, c, d, Num, Denom, Divis: Integer;  
Function gcd(a, b: Integer): Integer;
Var Temp: Integer;
Begin
  While b > 0 Do
  Begin
    Temp := b;
    b := a mod b;
    a := Temp
  End;
  gcd := a;
End;
Begin
  WriteLn('Введите числа A, B, C, D: ');
  Read(a, b, c, d);
  Num := a * d;
  Denom := b * c;
  Divis := gcd(Num, Denom);
  WriteLn(Num div Divis, '/', Denom div Divis);
End.
0,0(0 оценок)
Ответ:
lubochka2
lubochka2
03.10.2020 11:43
Function NOD(x,y:integer):integer;
begin
while (x<>0)and(y<>0) do
 if x>y then x:=x mod y else y:=y mod x;
NOD:=x+y;
end;
var a,b,c,d,n,z1,z2:integer;
begin
writeln('1-я дробь (числитель и знаменатель):');
readln(a,b);
writeln('2-я дробь (числитель и знаменатель):');
readln(c,d);
n:=nod(a*d,b*c);
z1:=a*d div n; 
z2:=b*c div n;
writeln(z1,'/',z2);
end.

Пример:
1-я дробь (числитель и знаменатель):
5 6
2-я дробь (числитель и знаменатель):
2 8
10/3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?