Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Fleksander
26.07.2020 16:35 •
Информатика
6. вычислить суммы элементов, для массивов х(10), y(20), z(25).
Ответ:
0Ева002
07.08.2020 13:14
/* gnu gcc */
#include <iostream>
#include <cstdlib>
using namespace std;
int main()
{
int x[10];
int y[20];
int z[25];
int xs=0, ys=0, zs=0;
// Заполняем массивы случайными числами до 100
srand(time(0));
cout <<"Массив X(10):" <<endl;
for(int i=0; i<10; ++i)
{
x[i] = rand() % 100;
cout <<x[i] <<" ";
}
cout <<endl;
cout <<"Массив Y(20):" <<endl;
for(int i=0; i<20; ++i)
{
y[i] = rand() % 100;
cout <<y[i] <<" ";
}
cout <<endl;
cout <<"Массив Z(25):" <<endl;
for(int i=0; i<25; ++i)
{
z[i] = rand() % 100;
cout <<z[i] <<" ";
}
cout <<endl;
// Считаем суммы элементов массивов
for(int i=0; i<10; ++i)
xs+=x[i];
for(int i=0; i<20; ++i)
ys+=y[i];
for(int i=0; i<25; ++i)
zs+=z[i];
cout <<endl;
// Выводим суммы элементов на экран
cout <<"Сумма элементов массива X(10) = " <<xs <<endl;
cout <<"Сумма элементов массива Y(20) = " <<ys <<endl;
cout <<"Сумма элементов массива Z(25) = " <<zs <<endl;
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Arino4ka7381
07.03.2023 06:43
скласти програму в python яка підраховує кількість додатніх та нульових серед введених користувачем чисел окремо...
nikiraspru
21.07.2021 16:40
В ПИТОНЕ! Напишите программу, которая выводит на экран максимальное из четырех целых чисел, введенных с клавиатуры. Используйте для написания программы словесный алгоритм.Прежде...
MaruaAvilova17
05.01.2022 21:15
Как называется таблица, которая показывает отношения между вершинами невзвешенного графа? И таблица, в которой отражен вес каждого ребра взвешенного графа?...
Діанагрeк
08.08.2021 16:20
сформировать и вывести на экран массив элементы которого заданы датчиком случайных чисел на интервале от -19 до 26 найти произведение элементов с нечетными номерами...
ppp13
13.08.2022 20:39
Скажите как сделать такую большую широкую стрелку в ворде?...
Sergeyii
15.12.2022 06:43
Установи соответствие между операторами присваивания и результатами их выполнения.a = float (14) - 8(10-14a = int(13.56) - 27FalseОООООa = str(45)6.0a = 23==21£)45...
LollyMelor
18.03.2021 18:08
В произвольном растровом изображении размеров 576x528 было использовано 250 цветов. При хранении изображения код цвета каждого пикселя записывается как двоичное число. Для...
Anechka6665
03.12.2020 12:00
Определите значение переменной х после выполнения цикла ...
Уляна2000002
30.10.2022 02:30
Запиши мантиссу числа и порядок числа 216000000=0,216⋅109. Мантисса числа: Порядок числа:...
steep6
28.09.2020 16:14
Выполните самостоятельно Задача No3Напишите программу, определяющую является ли числократным 7.Пример входных данных Пример выходных данныхх=28дах=32нет...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <iostream>
#include <cstdlib>
using namespace std;
int main()
{
int x[10];
int y[20];
int z[25];
int xs=0, ys=0, zs=0;
// Заполняем массивы случайными числами до 100
srand(time(0));
cout <<"Массив X(10):" <<endl;
for(int i=0; i<10; ++i)
{
x[i] = rand() % 100;
cout <<x[i] <<" ";
}
cout <<endl;
cout <<"Массив Y(20):" <<endl;
for(int i=0; i<20; ++i)
{
y[i] = rand() % 100;
cout <<y[i] <<" ";
}
cout <<endl;
cout <<"Массив Z(25):" <<endl;
for(int i=0; i<25; ++i)
{
z[i] = rand() % 100;
cout <<z[i] <<" ";
}
cout <<endl;
// Считаем суммы элементов массивов
for(int i=0; i<10; ++i)
xs+=x[i];
for(int i=0; i<20; ++i)
ys+=y[i];
for(int i=0; i<25; ++i)
zs+=z[i];
cout <<endl;
// Выводим суммы элементов на экран
cout <<"Сумма элементов массива X(10) = " <<xs <<endl;
cout <<"Сумма элементов массива Y(20) = " <<ys <<endl;
cout <<"Сумма элементов массива Z(25) = " <<zs <<endl;
return 0;
}