В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
BPANRUSSIA
BPANRUSSIA
17.07.2022 07:24 •  Информатика

Получить массив n=10 из следующих чисел [-15; 15].посчитать сумму элементов, которые заканчиваются на 5 и на 8. составить программу.

Ответ:
senyadubra
senyadubra
03.10.2020 11:33
Var b,sum:integer;
       a :array [0..31] of integer;
begin
sum:=0;
randomize;
for b:=0 to 9 do begin
 a[b]:= random(31)-15;
 writeln(a[b]);
if  (abs( a[b] mod 10) = 5) or (abs (a[b] mod 10) = abs(8)) then sum:=sum+a[b];
end;
writeln('сумма элементов оканчивавшихся на 5 или 8 = ',sum)
end.
0,0(0 оценок)
Ответ:
lesivarshavska
lesivarshavska
03.10.2020 11:33
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const n = 10;
var a: array[1..n] of integer;
  i,s:integer;
begin
  for i:=1 to n do begin
    a[i]:=random(31)-15;
    write(a[i]:4);
    if (abs(a[i]) mod 10 = 5) or (abs(a[i]) mod 10 = 8) then s:=s+a[i];
  end;
  writeln;
  writeln('Сумма оканчивающихся на 5 или 8 : ', s);
end.

Тестовое решение:
   8  12   4   2 -10  10 -10   2   8 -13
Сумма оканчивающихся на 5 или 8 : 16
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?