В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
аникдим
аникдим
15.02.2022 06:07 •  Информатика

Написать программу на языке c#, чтобы найти max{min(a, b), min(c, d)}

Ответ:
EgorKuleshov
EgorKuleshov
23.09.2020 23:24
Using System;
public class Test
{
    public static void Main()
    {
    int a, b, c, d, min1, min2, max;
    Console.Write("a = ");
    a = int.Parse(Console.ReadLine());
    Console.Write("b = ");
    b = int.Parse(Console.ReadLine());
    Console.Write("c = ");
    c = int.Parse(Console.ReadLine());
    Console.Write("d = ");
    d = int.Parse(Console.ReadLine());
    if (a < b) min1 = a; else min1 = b;
    if (c < d) min2 = c; else min2 = d;
    if (min1 > min2) max = min1; else max = min2;
    Console.WriteLine("max = {0}", max);
    System.Console.ReadKey();
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?