В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mrneneen
mrneneen
16.11.2021 21:05 •  Информатика

Написать программу на паскале для решения следующей : дан массив из 20 элементов. необходимо посчитать количество пар элементов, в которых есть хотя бы 1 нечетный элемент. под парой элементов считать 2 рядом стоящих элемента.

Ответ:
Galerina
Galerina
03.10.2020 11:31
// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
begin
  var a:=ArrRandom(ReadInteger('n='),-30,30);
  a.Println;
  var b:=a.Pairwise.Where(i->(i.Item1.IsOdd) or
    (i.Item2.IsOdd)).Count;
  Writeln('Количество пар= ',b)
end.

Тестовое решение:
n= 15
-5 7 12 -11 29 11 -28 19 20 28 -6 30 26 -14 27
Количество пар= 9
0,0(0 оценок)
Ответ:
Kaspiyskaya95
Kaspiyskaya95
03.10.2020 11:31
Const
  n = 20;

var
  a: array[1..n] of integer;
  m, i: integer;
begin
  for i := 1 to n do
  begin
    a[i] := random(21) - 10;
    write(a[i]:4);
  end;
  writeln;
  for i := 1 to n - 1 do
    if (a[i] mod 2 <> 0) or (a[i + 1] mod 2 <> 0) then m := m + 1;
  writeln('Всего пар', m);
end.

Тестовое решение:
   2  -8   8  -5   7  -8  -3  -6  -9   2  -1  -3  -8   6  10   7  -4  -8   0  -5
Всего пар 13
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?