В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Mogolan
Mogolan
12.09.2022 22:43 •  Информатика

Составить программу в паскале. найти количество положительных элементов массива х(3,3), заполненного с клавиатуры.

Ответ:
Шоколадка290
Шоколадка290
19.08.2020 15:56
Program foo;
var
b : array[1..3] of array[1..3] of integer;
c : integer;
i, j : byte;

begin
writeln('Заполните массив:');
for i := 1 to 3 do begin
writeln('Строка ', i);
for j := 1 to 3 do
readln(b[i][j]);
end;

c := 0;
for i:=1 to 3 do begin
for j:=1 to 3 do begin
write(b[i][j]:5, ' ');
if b[i][j] > 0 then inc(c, 1);
end;
writeln;
end;
writeln('Найдено ', c, ' положительных элементов');

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?