В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nikitka199821
nikitka199821
12.09.2022 22:43 •  Информатика

Написать программу в паскале вычислить значения функции y=tg(sinx)+2 при x=0,5; 0,7; 0,9; …; 2,1.

Ответ:
Rom4ik1105
Rom4ik1105
23.09.2020 22:22
// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
begin
  var x:=0.5;
  while x<=2.1 do begin
    Writeln('x=',x:3:1,' y=',tan(sin(x))+2);
    x+=0.2
    end
end.

Результат выполнения программы
x=0.5 y=2.5198809015013
x=0.7 y=2.75112025607465
x=0.9 y=2.99586604900996
x=1.1 y=3.23765167169871
x=1.3 y=3.43923041043966
x=1.5 y=3.5488600833871
x=1.7 y=3.52922062804747
x=1.9 y=3.38750383103094
x=2.1 y=3.16912357769899
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?