В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Craftrik
Craftrik
29.12.2020 06:47 •  Информатика

Написать программу,которая определяет количество всех чисел из диапазона от 5 до 25.(паскаль) входные данные: 1,6,35,12,18,24,0.

Ответ:
star1k
star1k
19.08.2020 15:56

Program Summa;

Uses Crt;

var s,n,c:integer;

 

 begin

   clrscr;

   write('Введите числа коннц ввода 0: ');

    s:=0;c:=0; 

    repeat

        readln(n);

        c:=c+1; 

if (n mod 2)=0 then
      if ((n>=5)and (n<=25)) then s:=s+n;        

  until (n=0) or (c=1000) ;    

write('Сумма ',c,' чётных чисел в диапазоне от 5 до 25:',s);

   readkey;

 

end. 
:D

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?