В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nazarovradion
nazarovradion
19.07.2022 20:01 •  Информатика

Напишите программу, которая заполняет массив из n элементов в обратном порядке последовательными натуральными числами, начиная с последнего элемента, который должен быть равен x . входные данные входная строка содержит два целых числа: начальное значение x и размер массива n , разделённые пробелом. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести содержимое массива: убывающую последовательность из n последовательных натуральных чисел; последний элемент должен быть равен x . программа - python ! только python

Ответ:
Sghem
Sghem
13.08.2020 21:21
Если правильно понял условие, то может быть так:

x,n = map(int,(input('input x,n ').split()))
a=[0]*n
print('input')
for i in range(n):
    a[i]= x-i
    print(a[i])
print('Output')
for i in range(n):
    print(a[i]+n-1)

Тестовое решение:
input x,n 10 5
input
10
9
8
7
6
Output
14
13
12
11
10
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?