В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
colins1987
colins1987
12.06.2021 16:48 •  Информатика

Составьте программу,заменяющую каждый из элементов t[i] массива t(n) минимальным среди первых i элементов данного массива.

Ответ:
elina184
elina184
13.08.2020 21:21
Pascal

var t:array [1..100] of integer;
j,i,n,m:integer;
begin
read(n);
for i:=1 to n do
read(t[i]);
m:=t[1];
for i:=2 to n do
if t[i]<m then m:=t[i];
read(i);
for j:=1 to i do
t[j]:=m;
for j:=1 to n do
write(t[j], ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?