В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
svashalol
svashalol
12.06.2021 16:48 •  Информатика

Составьте программу вычисления суммы тех элементов одномерного массива а(n), что расположены перед нулевым элементом данного массива.

Ответ:
Sanyaaa12
Sanyaaa12
07.08.2020 12:52
В C++
#include <iostream>
using namespace std;

int main() {
    const int N = 10;
    int A[N] = {12, 14, 6, 8, 23, 0, 23, 4, 5, 7}; //заполняем как-нибудь массив
    int i;
    int sum = 0;
    for (i = 0; i < N; i++)
        if (A[i] != 0)
            sum = sum + A[i];
        else
            break;
    cout << "Sum: " << sum << endl;
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?