В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zaharovdv73
zaharovdv73
23.04.2020 03:02 •  Информатика

Напишите программу, которая заполняет массив из n элементов случайными целыми числами в диапазоне [ a , b ] и определяет максимальный среди чётных положительных элементов этого массива. входные данные входная строка содержит три числа: границы диапазона случайных чисел a и b , а также размер массива n . все числа разделены пробелами. гарантируется, что 0 < n ≤ 10000 . выходные данные в первой строке программа должна вывести n элементов построенного массива, разделив их пробелами, а во второй строке – максимальный из чётных положительных элементов этого массива. если в массиве нет таких элементов, программа должна вывести число -1. b паскале

Ответ:
89286762165
89286762165
15.09.2020 22:25
// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
begin
  var n,a,b:integer;
  Read(a,b,n);
  var mas:=ArrRandom(n,a,b); mas.Println;
  var s:=mas.Where(x->x.IsEven and (x>0));
  if s.Any then Writeln(s.Max)
  else Writeln(-1)
end.

Тестовые решения:
-10 100 20
52 57 39 5 52 40 94 -2 -7 24 65 -6 22 77 2 41 48 83 19 69
94

-10 -2 8
-6 -9 -2 -8 -3 -9 -4 -7
-1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?