Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
sssmith
02.11.2022 23:29 •
Информатика
Найти сумму n первых нечётных натуральных чисел.(паскаль)
Ответ:
denchenchik02
07.08.2020 20:54
Var
n,i,a:integer;
Begin
Write('Введите число ');
Readln(n);
if n>=1 then Begin write('Сумма нечётных чисел от 1 до ',n,' = ');
for i:= 1 to n do
if ((i mod 2) <> 0) then a:=a+i;
write(a);
End else write('Введено число меньше единицы');
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
egorovaesya
10.03.2022 22:52
Составьте программу,каторая по задоннаму a исследует корни уравнения aх=5 и выводит на экран значение высленного корня либо сообщение корней нет...
sanimatronic
04.06.2023 12:41
Страница манускрипта содержит 90 строк по 40 символов в каждой. предсказание состоит из 4 манускриптов и имеет информационный обьем 45000 байтов. укажите мощность...
mrsuper773outlookcom
08.10.2020 00:22
2. Какое из чисел является наибольшим? 1) АВ162) 2418 3) 101110102 4) 162ответ дайте в десятичной системе счисления...
boginyanatasha
06.08.2021 04:54
Соедините каждую маску со всеми подходящими к ней файлами *list* summerreadinglist.txt * ??? liszt_ferenz.mp3 * revizor.fb2 *_* osennie_listya.jpeg...
лера25jd
17.04.2023 07:58
Пусть N — номер вашего варианта. Перевести в двоичный код и осуществить арифметические операции:1. N+52. N-503. N*(-6)4. (N+5)/4 ...
arinociIfca32
27.03.2022 11:57
Звуковая карта реализует 8-битовое кодирование аналогового звукового сигнала. Сколько различных значений амплитуды может быть закодировано таким ответ:...
Anna191203
06.07.2021 11:03
Сравнение единиц измерения информации ...
klassklassov
06.03.2023 16:00
125 в 8 системе + 101 в 2 системе × 2a в 16 системе - 141 в 8 системе =...
Dimkaumnik1
06.03.2023 16:00
Решить по информатике у шестиклассников аня боря вася галя даша и иван получили в подарок флешки на 1 2 4 8 16 32 гигабайта выясните у кого какая флешка у ани объем...
skosachyov
21.11.2021 01:49
Совсем скоро в уютном теплом гнездышке появится пёстрые птенчики разобрать предложение по членам указать часть речи...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n,i,a:integer;
Begin
Write('Введите число ');
Readln(n);
if n>=1 then Begin write('Сумма нечётных чисел от 1 до ',n,' = ');
for i:= 1 to n do
if ((i mod 2) <> 0) then a:=a+i;
write(a);
End else write('Введено число меньше единицы');
End.