В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
murat121221
murat121221
01.08.2021 18:41 •  Информатика

Дан двумерный массив. проверить, есть ли в нем одинаковые элементы. , , написать программу в паскале

Ответ:
dzorina2002
dzorina2002
03.10.2020 10:43
Program arr;
Const n=3;
var i, j, tmp, k, z:integer;
    c:boolean;
    a:array [1..n,1..n] of integer;

begin
c:=false;
for i:=1 to n do
  for j:=1 to n do
    read(a[i][j]);
for i:=1 to n do
  for j:=1 to n do
    begin
    tmp:=a[i][j];
    for k:=i+1 to n do
      for z:=j+1 to n do
        if tmp = a[k][z] then
        c:=true;
    end;
writeln;
for i:=1 to n do
begin
  for j:=1 to n do
    write(a[i][j], ' ');
  writeln;
end;
if c = true then
  writeln('В данном массиве есть равные друг другу элементы')
  else writeln('Элементы, равные друг другу, отсутсвуют в данном массиве');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?