В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Чай24
Чай24
23.09.2022 02:39 •  Информатика

)нужно сформулировать условие , которое решается в данной программе: program uses crt; var n: integer; s: byte; begin write('введите натуральное число: '); readln(n); s: =0 while n < > 0 do begin s: = s + n mod 10; n: =n div 10 end; writeln('s=',s: 4); end.

Ответ:
liloanimatronic
liloanimatronic
03.10.2020 10:40
1. Ошибка в коде: после S:=0 нет " ; "
2. Формулировка может быть такой:
Напишите программу, которая для натурального числа N получает сумму его цифр.
Программа на вход получает одно число N - натуральное. На выходе получаем одно число S - сумма цифр числа N.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?