В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Mazadinec
Mazadinec
05.02.2020 01:35 •  Информатика

Требовалось написать программу, при выполнении которой с клавиатуры считывается натуральное число n, не превосходящее 10^9, и выводится минимальная цифра этого числа. программист торопился и написал программу неправильно. pascal var n,k: integer; begin readln(n); k: =9; while n > 10 do begin if n mod 10 k: =n mod 10; n: n div 10; end; write(k) end. последовательно выполните следующее. 1. напишите, что выведет эта программа при вводе числа 537? 2. пример такого числа при котором программа работает верно 3.укажите все ошибки в программе и исправьте их.для этого для каждой ошибки выпишите строку ,которая написана неправильно и правильный вариант строки.

Ответ:
timofei2018
timofei2018
23.09.2020 16:15
Сначала надо избавиться от ошибок (пункт №3)
иначе не сможем выполнить 1 и 2 пункт задания.
  Исправляем if N mod 10 k:=N mod 10; на if (N mod 10 < k) then k:=N mod 10;
  Исправляем N:N div 10; на N:= N div 10;
 
После исправления ошибок при вводе 537 получим 3
Программа будет работать правильно для любого числа,
у которого вторая цифра слева меньше первой цифры, например:
7193

Чтобы программа работала правильно для всех чисел надо
изменить это: while N > 10 do на while N > 0 do

После всех исправлений код программы стал таким:
var
  N, k: integer;
begin
  readln(N);
  k := 9;
  while N > 10 do
  begin
    if (N mod 10 < k) then k := N mod 10;
    N := N div 10;
  end;
  write(k)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?