В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
koool3
koool3
17.02.2022 18:59 •  Информатика

Напишите программу, которая вычисляет сумму всех отрицательных чисел от 1 до n. если можно побыстрее, а то на завтра нужно.

Ответ:
тимур618
тимур618
03.10.2020 10:32
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  Writeln('s=',Range(ReadInteger('n='),-1).Sum)
end.

Тестовое решение:
n= -8
s=-36

"Школьный вариант"

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
var
  i,n,s:integer;
begin
  s:=0;
  Write('n='); Read(n);
  for i:=-1 downto n do s:=s+i;
  Writeln('s=',s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?