В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Moneyyyyyy
Moneyyyyyy
19.01.2021 23:52 •  Информатика

Напишите программу для решения следующей . на контрольной работе по ученикам 9 класса было предложено 10 примеров. неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. сколько неудовлетворительных оценок было получено учениками? если хотя бы один из учеников правильно решил все , выведите yes, иначе выведите no. программа получает на вход количество учеников в классе n (1 ≤ n ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров. (pascal) входные данные 4 3 9 2 8 выходные данные 2 no

Ответ:
gtagiev
gtagiev
23.09.2020 15:22
Var n,a,i,k:integer;
s:string;
begin
  s:='No'; k:=0;
  readln(n);
  for i:=1 to n do begin
    readln(a);
    if a<5 then k:=k+1;
    if a=10 then s:='Yes';
  end;
  writeln(k);
  writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?