В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
FROST1234567891011
FROST1234567891011
06.11.2020 19:13 •  Информатика

1. найдите наибольший элемент одномерного массива, состоящего из 12 элементов. элементы датчиком случайных чисел из интервала [-25,31] 2. массив а вводится с клавиатуры. найдите произведение отрицательных элементов с выводом на экран массива а

Ответ:
dawlatowaalbina
dawlatowaalbina
31.07.2020 17:50
1. в C++

#include <iostream>
#include <ctime>
int main()
{
    using namespace std;
    int ar[12];
    srand(time(0));
    for (int i = 0; i < 12; i++)
        ar[i] = -25 + rand() % 57;

    int temp = ar[0];
    for (int i = 0; i < 12; i++)
        if (ar[i] > temp)
            temp = ar[i];

    for (int i = 0; i < 12; i++)
        cout << ar[i] << "  ";

    cout << endl;
    cout << "Max: " << temp;
    cout << endl;
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?