Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
школьник62728474щ3
15.04.2020 07:16 •
Информатика
Составить программу вычисления количества натуральных нечётных чисел сумма квадратов которых не превысит 1000.( на паскале)
Ответ:
danylka33
15.09.2020 21:24
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var
a, s, n: integer;
begin
while s < 1000 do
begin
if a mod 2 <> 0 then begin
s := s + sqr(a);
n := n + 1;
end;
a := a + 1;
end;
writeln(n-1);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
DeteRno
05.01.2021 11:40
Какие типы корпусов бывают? Горизонтальный Вертикальный Башня Мини-башня Микро-башня Моноблок...
Dirijabl
25.11.2020 15:25
Як називаються підсумки, коли підрахунок проводиться не за всіма даними стовпця, а за іх частинами?1) проміжний2) суміжний3) підсумковий4) додатковий...
kostrominalekceu
01.08.2020 22:08
Путь в массиве хранятся числа 3,4,7,1,8,2,5,4,6,9 Разработайте блок-схему и код программы, которая будет находить число, введеное пользователем...
Ашка1231
10.12.2022 02:16
Наибольшее число x, для которого истинно высказывание (x четное) и (x =6) и не(x =22)...
poster1312
02.05.2020 14:19
Что выбирается раньше? 1)корпус 2)блок питания 3)только оба одновременно...
jinoguhaz
01.01.2021 20:01
Найти сумму всех чисел от 15 до N, кратных 3. Число N вводится с клавиатуры....
НастёнышЬ14
15.05.2021 23:20
Логические 5 вопросы про информатики...
Анна20041288
28.11.2020 06:46
Какое напряжение бывает на блоке питания? 30В 12В 10В 5В 3,5В 1В...
АкоLove
15.11.2020 21:50
по информатике 10 класс нужно сделать номер 4 и 5...
лизалол
29.03.2023 09:43
сделать программу по информатике. В одномерном массиве Z(100) все элементы, равные - 1 и 1, заменить числом 0...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
a, s, n: integer;
begin
while s < 1000 do
begin
if a mod 2 <> 0 then begin
s := s + sqr(a);
n := n + 1;
end;
a := a + 1;
end;
writeln(n-1);
end.