Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Ариса27
09.02.2021 15:53 •
Информатика
Написать программу вычисления факториалов всех чисел до n
Ответ:
baharaliyeva
15.09.2020 21:06
#include<iostream>
int fact(int x){ if(!x)return 1; return x*fact(x-1);}
using namespace std;int main(){int i=0;int n;std::cin>>n;do{ ++i; std::cout<<fact(i)<<"\n";}while(i<n);
return 0;}
0,0
(0 оценок)
Популярные вопросы: Информатика
amur3453
14.06.2020 14:10
в пайтон черепашке нарисовать ...
kalinka2002021oxuybb
25.08.2020 11:01
Моделдердің бір бірінен ерекшелігін сипаттаныз...
topova1
19.05.2021 15:40
Решите задачи через питон....
cat73309owz9do
20.09.2021 03:44
Число 137,11 записали в нормализованном виде. Выпишите порядок числа...
Eskhere
21.11.2020 11:41
Нарисовать блок-схему для следующей : вывести из трех чисел a, b, c два числа с наименьшими значениями....
Rezars19
12.12.2022 07:33
Впоход к озеру отправились гена,два его приятеля,маша,оля,а также брат маши витя и пёс вити-бим. сколько всего мальчиков отправились в поход? записать ответ и решение....
cheburek20
12.12.2022 07:33
Родители сделали ремонт в двух комнатах.длина первой комнаты 5, а ширина - 4м .вторая комната имеет ту же ширину, но на 2 м длиннее. за покраску потолка второй комнаты заплатили...
marcidus3Marcidus3
12.12.2022 07:33
Наука, изучающая живые организмы, называется...
GOKAS
12.12.2022 07:33
10 пословиц и поговорок, с глаголом во 2-м лице, единственном числе....
kozackilya1
12.12.2022 07:33
Решить две игрушечные машинки находятся на расстоянии 4395мм одна от другой одновременно они начинают двигатся в противопололожных напровлениях со скоростями 560 и 712мм/ мин...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
int fact(int x){ if(!x)return 1; return x*fact(x-1);}
using namespace std;int main(){int i=0;int n;std::cin>>n;do{ ++i; std::cout<<fact(i)<<"\n";}while(i<n);
return 0;}