Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
mvamz
18.03.2023 02:24 •
Информатика
Реьят напишите программу вычисления выражения: s=1! +2! +3! ++n! используйте функцию вычисления факториала
Ответ:
Reshebnikov
23.09.2020 08:54
Var n,i,s:integer;
function fact(k:integer):integer;
var j,f:integer;
begin
f:=1;
for j:=1 to k do f:=f*j;
fact:=f;
end;
begin
write('n='); readln(n);
s:=0;
for i:=1 to n do s:=s+fact(i);
writeln('s=',s);
end.
Пример:
n=5
s=153
0,0
(0 оценок)
Ответ:
yuriymakarov1
23.09.2020 08:54
// PascalABC.NET 3.1, сборка 1198 от 11.03.2016
function F(n:Integer):integer:=Range(1,n).Aggregate(1,(i,j)->i*j);
begin
Writeln(Range(1,ReadInteger('n=')).Select(x->F(x)).Sum);
end.
Тестовые решения:
n= 5
153
n= 10
4037913
0,0
(0 оценок)
Популярные вопросы: Информатика
snezhanakosola
08.11.2020 14:32
1) Как можно создавать модели в программе SketchUp 2) Каковы функции инструментов управления пространством в SketchUp3) Для выполнения каких действий используется...
ПолЕчка11117
12.09.2022 17:20
Напишіть,будь ласка, три задачі на вибір. Інформатика. тема:циклічні алгоритми...
Toktorovaskar
10.01.2020 07:59
Blender это программа для... 1) создание архитектурной визуализации2) создание сложных 3д моделей3)создание 3д моделей с высокой реалистичностью4) создание простых...
veselova999
24.03.2023 10:06
на у меня сор всего 1 вопрос а то...
jolyy
02.08.2020 19:38
с информатики 7 класс СОР за 3 четверть ...
9Mesut8
05.02.2021 14:13
5. Соотнесите к типам данных * 1/4, 25.6 Hello , 100 100, 250 Целые числа (int) Вещественные числа (Float) Строки (str) Целые числа (int) Вещественные числа (Float)...
елена1180
22.10.2021 00:39
Линейный алгоритм это: -описание действий, которые должны повторяться указанное число раз или пока не выполнено заданноеусловие-алгоритм при выполнении которого,...
мимими109
02.11.2021 18:04
по информатике сор 5 класс...
sodel28
17.10.2022 12:21
Изучите ниже приведенный рисунок и определите действия, которые выполняет робот из предложенных блоков программы ...
osipovalex1969
25.10.2020 22:00
Музыкант слышит музыку и записывает её в нотах. какие преобразования здесь происходят. и как?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
function fact(k:integer):integer;
var j,f:integer;
begin
f:=1;
for j:=1 to k do f:=f*j;
fact:=f;
end;
begin
write('n='); readln(n);
s:=0;
for i:=1 to n do s:=s+fact(i);
writeln('s=',s);
end.
Пример:
n=5
s=153
function F(n:Integer):integer:=Range(1,n).Aggregate(1,(i,j)->i*j);
begin
Writeln(Range(1,ReadInteger('n=')).Select(x->F(x)).Sum);
end.
Тестовые решения:
n= 5
153
n= 10
4037913