В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
konfetkaa2004
konfetkaa2004
12.01.2021 21:13 •  Информатика

Вкладчик внес в сберкассу x рублей. написать программу,вычисляющую,сколько денег будет у него через n лет. кол-во денег каждый год увеличивается на 3 % по отношению к предыдущему году.

Ответ:
RFTBOY
RFTBOY
28.05.2020 00:30

program test;
var years: integer; contribution: real;
begin
   write('Enter the contribution sum: ');
   readln(contribution);
   write('Enter the number of years: ');
   readln(years);

   while years <> 0 do
   begin
      contribution:=contribution+(contribution / 100 * 3);
      years:=years-1;
   end;

   writeln(contribution:0:2, ' rub');

   readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?