В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ksuz
ksuz
06.09.2020 23:19 •  Информатика

Написать программу которая для заданного натурального числа n вычисляет сумму 1+1/1+2+1/1+2+3+···+1/1+2+···n в паскале .

Ответ:
еьпа
еьпа
03.10.2020 09:25
Var s: real;    n,sn,i: integer;begin  write('n = ');  readln(n);  s:=0;  sn:=0;  for i:=1 to n do  begin    sn:=sn+i;    s:=s+1/(sn);    writeln(s);  end;  writeln('сумма ряда:  ',s);end.    
0,0(0 оценок)
Ответ:
Stikki
Stikki
03.10.2020 09:25
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
//Наверное здесь опечатки 1+1/1+2+1/1+2+3+···+1/1+2+···n скорее всего имелось ввиду так:
//1+1/(1+2)+1/(1+2+3)+···+1/(1+2+···n)
var i,n:integer;
s,s1:real;
begin
  readln(n);
  s:=0;s1:=0;
  for i:=1 to n do begin
    s1:=s1+i;
    s:=s+1/s1;
  end;
  writeln (s);
  end.
 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?