В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
galkaoks056
galkaoks056
24.03.2020 21:15 •  Информатика

Написать программу, вычисляющую значение функции: y = cosx+cos2x+cos3x+…+cos30x

Ответ:
tarasovdanila
tarasovdanila
30.08.2020 20:57
//Pascal ABC.NET v3.1 сборка 1172

Var
 y,x:real;
 i:integer;
begin
 readln(x);
 for i:=1 to 30 do
 y:=y+cos(x*i);
 writeln(y);
end.

Пример ввода:
1
Пример вывода:
-1.32716415333901
0,0(0 оценок)
Ответ:
nebeca
nebeca
30.08.2020 20:57
// PascalABC.NET 3.1, сборка 1192 от 07.03.2016
begin
  var x:=ReadReal('x=');
  Writeln(Range(1,30).Select(i->cos(x*i)).Sum)
end.

Тестовое решение:
x= 0.385
-2.41774673342197
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?