Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
sashashenko
28.08.2022 14:03 •
Информатика
Паскаль даны натуральные числа n и k. написать программу вычисления выражения 1^k+2^k+3^k+4^k+…+n^k
Ответ:
Alinaakconova9
03.10.2020 09:14
// PascalABC.NET 3.1, сборка 1190 от 05.03.2016
begin
var n:=ReadInteger('n=');
var k:=ReadInteger('k=');
var s:=Biginteger(0);
for var i:=2 to n do s+=Power(Biginteger(i),k);
Writeln('Сумма ',s+1)
end.
Тестовые решения:
n= 10
k= 30
Сумма 1043651859661187698792930519525
n= 5
k= 2
Сумма 55
n= 38
k= 67
Сумма 8400313720757760689953535296227476513296331784292134843927352320607786766609162308796108536127867158913721
0,0
(0 оценок)
Популярные вопросы: Информатика
Inna050798
16.05.2022 20:20
Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать).сделайте...
pmangaskin
17.04.2021 12:53
Среди двузначных чисел найти те, сумма квадратов цифр которых делится на13...
Песатель
17.04.2021 12:53
Ваш друг предлагает вам переписать отснятый им видеофильм. из носителей информации у вас есть: компакт-диск объемом 650 мб, дискета объемом 1мб и флеш-накопитель объемом 1000мб....
anya64yankop08swl
05.11.2022 14:17
Даны вещественные числа a1, a2, …, a10. Верно ли, что их сумма превышает 100,78?...
gulim160104
05.02.2020 07:12
В электронной таблице значение формулы =срзнач (А6:С6) равно 0.1 чему равно значение формулы =сумм (А6:D6) если значение ячейки D6 равно (-1)...
Fidjit
17.11.2020 02:03
ТЕКСТ ЗАДАНИЯ Составьте программу определения целой части от деления чисел 63 на 15...
оспшро
11.02.2022 22:40
Сопоставь варианты упорядочивания элементов массива...
StesnyaШka
18.01.2020 23:59
Соотнеси строки кода и их назначение...
лера12061206
12.08.2021 13:29
Сопоставь встроенные функции и методыСПИСКОВ...
kotikzxp
13.11.2021 01:06
Задание 1. (3) Дан программный код по следующей задаче: Вводится значение температуры воздуха и выдачи текста хорошая погода если 10 градусов и текста «Плохая погода! »»,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// PascalABC.NET 3.1, сборка 1190 от 05.03.2016
begin
var n:=ReadInteger('n=');
var k:=ReadInteger('k=');
var s:=Biginteger(0);
for var i:=2 to n do s+=Power(Biginteger(i),k);
Writeln('Сумма ',s+1)
end.
Тестовые решения:
n= 10
k= 30
Сумма 1043651859661187698792930519525
n= 5
k= 2
Сумма 55
n= 38
k= 67
Сумма 8400313720757760689953535296227476513296331784292134843927352320607786766609162308796108536127867158913721